Et maintenant ?

Modérateur: Modérateurs et Modératrices

Et maintenant ?

Messagede Andre » 13 Nov 2004, 12:08

Bonjour,
Je suis un débutant parmis les débutants de Linux. J'ai trouvé l'antivirus http://dl.antivir.de/dateien/antivir/re ... vlxwks.tgz sur la fiche Antivirus Personal Edition (j'utilise habituellement la version idoine sous Wxp et W98), et je l'ai téléchargé. Ce fichier s'est posé sur /home/andre/tmp.
Et maintenant, qu'est-ce que je dois faire pour activer cet antivirus ? Quels sont les gestes à accomplir ? Le b a ba, quoi !
Merci de votre patience à venir.
Andre
Ubuntu
mais aussi Wxp sp2 et W98
Andre
 
Messages: 94
Inscription: 27 Oct 2004, 16:05
Localisation: Le vignoble des Côtes de Blaye

Messagede Jim Rakoto » 14 Nov 2004, 19:54

Salut,

Tesgaz a expliqué dans un post qu'il n'était pas nécessaire d'installer un antivirus quand on utilise Linux. Mais si tu veux le faire voici qq explications.
D'abord le site de Lea qui explique comment compiler une application

http://lea-linux.org/software/compil.html

l faut d'abord décompresser le package dans le répertoire de votre choix. /usr/src me semble un bon choix, mais vous êtes libres. (dixit Lea)
donc dans ton cas : ouvrir une console, et se mettre en root
taper su > enter
taper mot de passe administrateur
[root@andre root]# cd /usr/src
[root@andre root]# tar zxvf /home/andre/tmp/le_package.tar.gz
[root@andre appli]# ./configure
un écran s'affiche avec lignes
[root@andre appli]# make
lignes s'affichent à l'écran
[root@andre appli]# make install
idem

"Appli" doit être remplacé par le nom du fichier antivir .

Il existe également un application graphique pour se faciliter l'utilisation de l'antivirus Antivir
http://www.sebastian-geiges.de/cms_e/fr ... hp?idcat=6

A+
Mes configs Linux user #402189
Garder toujours son sens critique en éveil en utilisant le doute rationnel comme filtre de lecture.
Avatar de l’utilisateur
Jim Rakoto
Modérateur
 
Messages: 6152
Inscription: 09 Mar 2004, 19:49
Localisation: Durbuy

Messagede Andre » 14 Nov 2004, 21:06

Merci, Jim

Le temps de rebooter (je suis sous Wxp), et je vais suivre tes instructions.

@+
Ubuntu
mais aussi Wxp sp2 et W98
Andre
 
Messages: 94
Inscription: 27 Oct 2004, 16:05
Localisation: Le vignoble des Côtes de Blaye

Ca y est (presque)

Messagede Andre » 14 Nov 2004, 22:43

Re bonsoir, Jim

Avec ton aide et celle de LEA qui dit ''il est fortement recommandé de lire les fichiers README et INSTALL avant de commencer'', l'installation s'est apparemment bien passée. Bien sûr, j'ai cherché un peu (où serait le plaisir sans cela ?) En fait, il n'y a pas de fichier ./configure. La commande à lancer est ./install. Bon, ça s'est passé sans problème. Mais je ne pense pas que Antivir tourne. Je ne vois pas le parapluie comme sous Wxp (il n'est pas possible d'effacer en un instant 20 années de culture Micro$oft), et le moniteur système Gnome n'a pas l'air d'en faire état dans les processus lancés.

Ce sera donc ma question suivante : une fois installée, comment lancer ce programme ?

Et merci encore pour ces résultats encourageants et pour votre patience à tous.

André
Ubuntu
mais aussi Wxp sp2 et W98
Andre
 
Messages: 94
Inscription: 27 Oct 2004, 16:05
Localisation: Le vignoble des Côtes de Blaye

Messagede Jim Rakoto » 15 Nov 2004, 08:22

Salut,

tu peux voir comment le montage s'est passé en allant dans "démarrer" (pour garder un point de repère) > système > surveillance système > log système.
Tu regardes ce jour et hier ce qui est indiqué dans log.
Ceci dit faudrait que je regarde car je ne sais pas si Antivir fonctionne avec un module résident dans Linux ou si on l'utilise uniquement pour des scans

tu peux toujours taper : antivir --help
tu devrais avoir infos

A+
Mes configs Linux user #402189
Garder toujours son sens critique en éveil en utilisant le doute rationnel comme filtre de lecture.
Avatar de l’utilisateur
Jim Rakoto
Modérateur
 
Messages: 6152
Inscription: 09 Mar 2004, 19:49
Localisation: Durbuy

Messagede Andre » 15 Nov 2004, 09:32

Bonjour, Jim

Il semble que l'on active cet antivir à la demande. J'ai joué avec les commandes apparues avec antivir --help :

J'ai tapé
[andre@localhost andre]$ antivir
Loading /usr/lib/AntiVir/antivir.vdf ...

Warning: The file "antivir.vdf" is more than 14 days old.

AntiVir is running in DEMO mode.
VDF version: 6.28.0.2 created 22 Sep 2004

checking drive/path (cwd): /home/andre

------ scan results ------
directories: 1
scanned files: 0
skipped files: 25
alerts: 0
suspicious: 0
scan time: 00:00:01
--------------------------
Thank you for using AntiVir.

Il semble donc que antivir soit installé, même si le résultat n'est pas terrible !

Merci de ton aide et de ta patience !
A+
Ubuntu
mais aussi Wxp sp2 et W98
Andre
 
Messages: 94
Inscription: 27 Oct 2004, 16:05
Localisation: Le vignoble des Côtes de Blaye

Messagede Tesgaz » 15 Nov 2004, 09:52

Salut,


les commandes pour antivir c'est celle-ci :
antivir --help " print help"
antivir --version "print version information"
antivir -q "quiet mode"
antivir -s "recursive scan"
antivir -z " scan within compressed files"
antivir -e "repair concerning files (if possible)"
antivir --allfiles "scan all files (instead of just program files)"
antivir --update "check for a newer version of AntiVir or the"
data files


mais comme un antivirus ne sert à rien sur linux, je l'avais juste testé pour voir,
Avatar de l’utilisateur
Tesgaz
 
Messages: 2133
Inscription: 23 Juil 2004, 12:49
Localisation: ici : ---------------------> X

Messagede Andre » 15 Nov 2004, 10:07

Re Bonjour

Certes, l'antivirus n'est pas vraiment utile sous Linux. Cependant, avec ton aide, j'ai réalisé une manip qui fonctionne, et je t'en remercie. Mes essais précédents s'étaient tous soldés par des messages d'erreur incompréhensibles pour moi et décourageants. Je vais pouvoir essayer maintenant d'installer d'autres applications, comme un firewall, par exemple, mon objectif étant d'abord d'apprendre à maîtriser Linux-Mandrake.

Merci encore de ta patience et de ton aide.
Ubuntu
mais aussi Wxp sp2 et W98
Andre
 
Messages: 94
Inscription: 27 Oct 2004, 16:05
Localisation: Le vignoble des Côtes de Blaye

Messagede Tesgaz » 15 Nov 2004, 10:23

re salut,

il existe un parefeu d'origine sur la mandrake "Shorewall"
pour le configurer, il faut aller dans le panneau de controle "configurer l'ordinateur"
=> sécurité => pare feu

et activer ou desactiver les divers services
Avatar de l’utilisateur
Tesgaz
 
Messages: 2133
Inscription: 23 Juil 2004, 12:49
Localisation: ici : ---------------------> X

Messagede Andre » 15 Nov 2004, 21:27

Bonsoir, Tesgaz

Merci de l'aide sur le firewall "Shorewall".
J'ai configuré le pare feu avec la boite de dialogue DrakFirewall. J'ai utilisé l'aide en ligne, qui précise, je cite ''Si vous pensez n'héberger aucun service sur votre machine (cas le plus courant pour une simple machine de bureau), décochez toutes les cases.'' C'est ce que j'ai fait. Alors, je ne peux plus aller sur internet ! Le firewall bloque toutes mes demandes de sortie : assiste.free.fr devient introuvable, ainsi que tout autre site. Je n'ai pu me reconnecter au forum que en cochant la case ''Tout (pas de firewall)''. Je n'ai pas tout compris.

Bonsoir, et merci encore.

Andre

Edité aprés essais complémentaires : même si toutes les cases sont cochées, les sites restent ''introuvables''. Il est nécessaire de cocher ''Tout (pas de firewall)'' pour pouvoir joindre les sites.
Ubuntu
mais aussi Wxp sp2 et W98
Andre
 
Messages: 94
Inscription: 27 Oct 2004, 16:05
Localisation: Le vignoble des Côtes de Blaye

Suivante

Retourner vers Linux (toutes distributions) et moi

Qui est en ligne

Utilisateurs parcourant ce forum: Google [Bot] et 2 invités