Page 1 sur 6

configurer un wifi usb sous debian

MessagePosté: 09 Nov 2007, 01:05
de MethodMan
J'ai un dongle wifi de marque Linksys, modèle WUSB54G. Le problème c'est que je n'arrive pas à me connecter à internet avec mon dongle.
Si je dois éventuellement installer des pilotes, où les avoir? et que faire comme configuration?

Merci pour vos réponses

MessagePosté: 09 Nov 2007, 11:46
de piratebab
Bonjour,
on va pratiquer par ordre (ce qui devrai te plaire vu ton pseudo!).
D'abord identifier précisément le chip utilisé par le dongle (avoir la marque du dongle ne suffit pas toujours, parfois les constructeurs font des évolutions sans rien dire).
Je suppose que tu sais ouvrir une console et passer en root:
Code: Tout sélectionner
#lsusb


Tu cherches la ligne avec du wireless et tu la colles ici.
ensuite la version du noyau:
#uname -a


Avec ça, on verra quel driver est à installer.

A tout hazard, fait aussi un
Code: Tout sélectionner
#iwconfig

et colle le résultat, le driver est peut être déjà installé.
Au fait, quelle distribution linux utilises tu ? (n'oublie pas de remplir ton profil) C'est la debian fraichement installée ?

MessagePosté: 09 Nov 2007, 18:35
de MethodMan
Bonjour,
Comme distribution linux, j'utilise bien Debian. Eh oui c'est la Debian fraichement installée

voici les resultats des différentes commandes

Pour #lsusb, j'ai pas eu des ligne marqués par wireless. J'ai plutot eu une ligne avec le nom du fabricant de mon dongle:

Bus 003 Device 002: ID 13b1:000d Linksys

Pour la version de mon noyau, on a:

2.6.18-5-686 #1 SMP Fri Jun 1 00:47:00 UTC 2007 i686 GNU/Linux

Et puis la commande #iwconfig à donner:

lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

Merci

MessagePosté: 09 Nov 2007, 19:33
de piratebab
Bonsoir,
résumons la situation
ton dongle semble avoir un chip ralink (peu d'infos sur le net pour ce modèle). source: http://www.linuxmint.com/forum/viewtopic.php?t=286
Tu as plusieurs possibilités
1) installer les drivers proprio. C'est ce que j'ai sur un noyau 2.6.18 comme le tiens.
Tu dois les avoir sur le CD de ton dongle. Mais tu peux les prendre directement sur le site de ralink
http://www.ralinktech.com/ralink/Home/Support/Linux.html
Firmware RT2501USB(RT2571W/RT2671)
Un bon tuto pour ces drivers: http://forum.debian-fr.org/viewtopic.php?f=8&t=6135, en adaptant pour l'USB

2) installer les drivers libres. C'est beaucoup plus simple, mais je sais par expérience, qu'ils ne fonctionnent pas avec un noyau 2.6.18.
Mais j'aimerai savoir pourquoi tu as ce noyau. Tu es apparemment en version debian stable. Pourquoi ne pas passer en testing ? Tu auras tout les logiciels et drivers récent (et un notau 2.6.22), et c'est trés stable comme version pour un laptop (pour un serveur ce serai différent).

MessagePosté: 10 Nov 2007, 08:56
de piratebab
Bonjour,
pour passer de debian stable (etch) à testing (lenny), il suffit d'avoir une liaison internet qui marche.
Tu vas commencer par modifier la liste des dépôts qui se trouve dans /etc/apt/sources.list.
C'est un fichier système, seul l'utilisateur root peut le modifier.
Donc tu ouvres une console, tu tapes kdesu konqueror, et tu travailleras ainsi en root.
Tu remplace dans ce fichier "etch" (ou "stable" par testing)
Tu l'enregistres.
Dans une console, en root:

aptitude update
aptitude upgrade
aptitude dist-upgrade

ça risque d'étre un peu long suivant le debit de ta connexion!

Quand tout est fini, tu rebootes, et tu es en testing (mais peut être toujours avec l'ancien noyau, je ne sais plus si l'install auto de debian active la mise à jour automatique du noyau).
Vérifie avec un uname -a.
Lorsque tu en sera là, on poursuivra.
(mise à jour éventuelle du noyau, puis install des drivers)

MessagePosté: 10 Nov 2007, 10:42
de jessminder
non

il conservera l'ancien noyau.

Il faudra charger le nouveau et désinstaller l'ancien si le 2.6.22 lui convient.

Concernant le passage de Etch ( stable) à Lenny ( testing), moi ça m'a pris... 650 paquets environ et 35mn de téléchargement à 200 kb/s

MessagePosté: 10 Nov 2007, 10:47
de piratebab
Salut jess,
sur ma dernière install de testing, j'avais la mise à jour auto du noyau activée.

MessagePosté: 10 Nov 2007, 10:50
de jessminder
:? zut moi pas!

Tu as fait comment?

J'ai passé ma Etch -> Lenny -> Unstable et à chaque fois, j'ai du charger le nouveau noyau !

MessagePosté: 10 Nov 2007, 11:58
de piratebab
Je n'ai rien fait de spécial, mais de toute façon je n'aime pas les mises à jour auto du noyau. Je l'ai désactivé.

MessagePosté: 10 Nov 2007, 11:58
de Tesgaz
apt-get dist-upgrade

ca ne fonctionne que si tu as grub,car il met à jour automatiquement